You are viewing an archive of the old fxhome.com forums. The community has since moved to hitfilm.com.

Plugger help

Posted: Mon, 29th Mar 2004, 6:38pm

Post 1 of 5

LewisM

Force: 210 | Joined: 14th Oct 2003 | Posts: 27

EffectsLab Lite User

Gold Member

I've created a few plugins using 3D software and everything works fine in Alam except I want to make modifications to what I created. I try to delete the files, however, Alam gives me an error message when I try to start it up (something about expecting an "object"). If I put the files back, then it works fine. I have deleted other pluggins sucessfully before, but with these (5) I have been having difficulty. Any solution to suggest?

Also, I have some questions regarding setting up attributes and layers ...is there any guidance for this other than what is in the AlamDV2 manual.

confused

Clue
Posted: Tue, 30th Mar 2004, 7:00am

Post 2 of 5

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

The manual covers it pretty well. Is there something missing, or do you just need it explained a little better? Either way, I can help you out. Give me your question, I'll give you an answer. smile I've used and researched the Plugger pretty extensively, so I can probably help you through whatever difficulties you run into.

Couple questions on your deleting plugins issue: What operating system are you running?

Are you launching AlamDV by clicking the program icon, or by opening a project?
Posted: Tue, 30th Mar 2004, 3:07pm

Post 3 of 5

LewisM

Force: 210 | Joined: 14th Oct 2003 | Posts: 27

EffectsLab Lite User

Gold Member

I am running Win XP Home and to start the program, I click on the AlamDV2 shortcut I've created.

It seems a little strange because the plugins actually work, but when I try to delete them after closing the program, I get an error message and the program won't open up. I put them back and there is no problem. I should say that each of the pluggins have a very similar name i.e spark ricochet 3oc, spark ricochet 4oc etc (5 in total). It is also odd, that I can delete the 3oc, with no problem.

The questions I have are 1) how to add transparency adjustment to a plugin and 2) using Add pin, I can successfully remove the black background, but it also removes any black within the object. Is there a better way to do this?

clue neutral
Posted: Tue, 30th Mar 2004, 5:20pm

Post 4 of 5

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Ah, well, the solution to both of your plug-in questions is... Alpha channels! In order to get the transparency slider, you have to have alpha channels in your images. If the alphas are in place, the transparency control will be automatically created. And as for removing black outside of, but not inside your object, again, alpha channels. Add Pin is for luminescence effects (light sources); for 3d objects of any kind, you want to use alpha channels. If you are creating them in a 3d program, there is a good chance that when you render you can render the images with alpha channels already in place. If not, here is a link that explains how in Photoshop, and here is a link explaining the process in Pain Shop Pro. There is also a simplified tutorial on creating this type of plugin right here .

I'm not sure on the deleting plugins thing though. I'll have to see what I can find.
Posted: Wed, 31st Mar 2004, 3:58pm

Post 5 of 5

LewisM

Force: 210 | Joined: 14th Oct 2003 | Posts: 27

EffectsLab Lite User

Gold Member

Thanks for your help Axeman,
The information you provided was enough to figure out how to get the 3D animation (created in Blender 2.32) into the Plugger with the alpha channels intact...I must admit it took a bit of time...but success at last.

Regarding the inability to delete the files...that was related to renaming some of the files from Spark Ricochet to Sparks Ricochet...I checked the script files and noticed the difference. made the appropriate change and restarted AlamDV...it uploaded what it saw as a new plugin...then I could delete them.

Thanks again...
I'm looking forward to creating many cool plugins.

Clue
biggrin