You are viewing an archive of the old fxhome.com forums. The community has since moved to hitfilm.com.

Dissapearing muzzle flash? [ANSWER]

Posted: Wed, 8th Aug 2007, 3:44am

Post 1 of 5

gcgipson

Force: 400 | Joined: 24th Mar 2005 | Posts: 5

EffectsLab Pro User

Gold Member

Hmmm, I noticed that my muzzle flash sometimes randomly doesn't show itself when I play my video through certain PC applications (like Sony's DVD Architect, for example.) Why is this?
Posted: Wed, 8th Aug 2007, 4:10am

Post 2 of 5

ares89

Force: 400 | Joined: 15th Aug 2005 | Posts: 6

CompositeLab Pro User EffectsLab Pro User

Gold Member

Maybe the effect happened so fast that the program itself blends the frames together to cover up the effect. I have noticed most pistol muzzle flashes only last one frame when you apply them. I might be completely wrong though, try increasing the length in the muzzle flash to 2-3 frames.
Posted: Wed, 8th Aug 2007, 5:43am

Post 3 of 5

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

If your project is interlaced, as most dv footage generally is, then each field is shown on the EffectsLab timeline. A single frame of the video is actually made up of two fields on the timeline. so if your muzzle flash is only one field in length, it may not appear sometimes when played back on a computer. If you were to play it back on a television, which is interlaced, you would see it, but on a computer monitor, which is progressive, many programs play back only a single field for each frame, to avoid combing. If the field which is dropped was the one containing your flash, it will not show up.

The solution, as ares98 suggested, is to make sure each muzzle flash lasts two fields, or one full frame, or longer.
Posted: Wed, 8th Aug 2007, 1:21pm

Post 4 of 5

gcgipson

Force: 400 | Joined: 24th Mar 2005 | Posts: 5

EffectsLab Pro User

Gold Member

Thanks everyone, no worries, actually. Once I put my HDV 24p footage onto DVD, the muzzle flash is always there. I think the disappearance of it on the computer has something to do with the lack of a pulldown, I don't know. Anyway, I have tested the muzzle flash out on three different DVDs, and it shows itself every time now. Thanks.
Posted: Thu, 9th Aug 2007, 2:29am

Post 5 of 5

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Yeah, as I said earlier, when played back on an interlaced screen, they will show up.