You are viewing an archive of the old fxhome.com forums. The community has since moved to hitfilm.com.

Export Just the Keyed Subject with Transparent Backround

Posted: Sat, 28th Feb 2009, 8:47pm

Post 1 of 8

cottonj

Force: 400 | Joined: 28th Feb 2009 | Posts: 1

PhotoKey 2 User

Gold Member

The keying quality of Photokey is the best I've seen. Once the app has keyed the subject, I would like to export just the key with a tranparent background. When I export via Tiff and open the tiff image in Photoshop CS4, the subject is on a dark gray background. What am I doing wrong?
Posted: Sun, 1st Mar 2009, 2:21am

Post 2 of 8

TubeTape

Force: 9542 | Joined: 24th May 2007 | Posts: 169

VisionLab User VideoWrap User PhotoKey 5 Pro User PhotoKey 3 Plug-in User FXpreset Maker Windows User MacOS User

Gold Member

I just experienced the same thing importing to Photoshop CS3. However, if I export the image as PNG the transparency works fine.
Posted: Mon, 2nd Mar 2009, 9:30am

Post 3 of 8

Simon K Jones

Force: 27955 | Joined: 1st Jan 2002 | Posts: 11683

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker Windows User

FXhome Team Member

Hm, I just tried exporting to a TIFF and it included the alpha channel info without any problems.

Could you confirm your canvas settings? It would also be useful if you could send the original foreground image and the problem TIFF to support@fxhome.com so we can take a look.
Posted: Wed, 18th Mar 2009, 10:56pm

Post 4 of 8

spaghetti man

Force: 1410 | Joined: 15th Aug 2007 | Posts: 43

VisionLab User PhotoKey 2 User

Gold Member

Odd. I'm having a similar issue. Was this problem resolved? I'am using the demo if that has anything to do with it.

Thanks for the assistance.
Posted: Thu, 19th Mar 2009, 12:14am

Post 5 of 8

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Alpha export is likely disabled in the demo.
Posted: Thu, 19th Mar 2009, 11:18am

Post 6 of 8

JackPot

Force: 10109 | Joined: 3rd Oct 2005 | Posts: 384

VisionLab User VideoWrap User PhotoKey 3 Pro User MuzzlePlug User PowerPlug User FXpreset Maker Windows User MacOS User

Gold Member

Alpha export is not disabled in the demo. Could you send the exported image you are having trouble with to team@fxhome.com

Thanks

- Jack
Posted: Thu, 16th Apr 2009, 2:54am

Post 7 of 8

toddg

Force: 0 | Joined: 16th Apr 2009 | Posts: 3

Member

I'm seeing the same thing... the keying is GREAT..but when I export as TIFF into CS3 or CS4 I get a gray background instead of just the keyed selection...if I save as a .PNG it seems to work fine
Posted: Sun, 19th Apr 2009, 3:48am

Post 8 of 8

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

OK, I've been playing around with this a bit myself, and the TIFF files you are exporting have all of the alpha info included in them, its just the way they are displayed in Photoshop. If you look at the channels you will see that the alpha channel is there, its just not visible by default. If you create a selection based on the alpha channel, then use that to create a layer mask for the layer, you should be good to go quite quickly.