You are viewing an archive of the old fxhome.com forums. The community has since moved to hitfilm.com.

Particles Not Showing!

Posted: Thu, 16th Jul 2009, 4:12am

Post 1 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

Help! I only have a couple of days left to get a fully working version of my feature to the distributors and I have struck yet another problem. I have 3 systems constantly rendering, however on my MacBook whenever I try to load in a file that features the "realistic flamethrower" preset, the particles are all just large white squares.

I have clean installed several times and reimported the presets but to no avail. Works perfectly on my Hacintosh and my iMac though...

Can anyone help? I REALLY need the three machines up and running properly.
Posted: Thu, 16th Jul 2009, 4:21am

Post 2 of 14

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Odd that only the one machine would have the problem repeatedly. The white square indicate missing texture files though. Make a not of the texture files that are used in the effect, then go to ~/Documents/FXhome/VisionLab Studio 1.5/media/texture and make sure the files are there. If not, copy them from one of the other computers to that folder, and you should be good to go. If this doesn't work, let us know, and we'll figure something out.
Posted: Thu, 16th Jul 2009, 4:23am

Post 3 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

Thans for the quick response. I don't think that's it as when I bring a new realistic flamethrower in it works fine - just on the pre existing ones. For example, I loaded up a project with rocketship flames that just appeared as white squares , I then added a new flamethrower to see if it would work and it did....
Posted: Thu, 16th Jul 2009, 4:28am

Post 4 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

I'll try another clean reinstall, re-download the preset in case it is corrupt and then import that one preset on its own and see if that works...
Posted: Thu, 16th Jul 2009, 4:48am

Post 5 of 14

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Sounds good; let us know how it goes...
Posted: Thu, 16th Jul 2009, 5:03am

Post 6 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

Nope, still not working.
Posted: Thu, 16th Jul 2009, 5:05am

Post 7 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

Okay, it was the textures but not that they weren't there - I needed to relink them... odd. Could this be because I'm using an external HDD?
Posted: Thu, 16th Jul 2009, 5:08am

Post 8 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

I have to relink all my BG files when using the ext HDD on different machines too....
Posted: Thu, 16th Jul 2009, 5:17am

Post 9 of 14

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Hmmm, if the texture folder is on an external drive, that would make sense, as VisionLab is always going to look in the Documents folder of the current user account on the primary drive, so if they were stored elsewhere, you would have to re-link them. It shouldn't be looking there for bg files though.

So does saving the project not save the directory paths to the pertinent files (bg's and textures) when they are on external drives? If that's the issue, then this is a job for schwar and company, not me. But at least re-linking can keep you running in the meantime?
Posted: Thu, 16th Jul 2009, 5:31am

Post 10 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

Yeah, I'll just relink. I'm using time machine drives so can't save. lol. All finished files though so no need to save.
Posted: Thu, 16th Jul 2009, 5:37am

Post 11 of 14

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Good deal that you are still able to continue anyway. So if you want to post a detailed explanation here of what exactly the program is doing, and what you would like it to do, or think it ought to do, then maybe sometime in the future the crew can look at the implementation of how files are handled on external drives to see if they can improve it.
Posted: Thu, 16th Jul 2009, 5:39am

Post 12 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

The only things I'd like are batch rendering and the ability to use bigger files... pretty annoying having the program crash and losing projects because the image files are over 1920x1080...

All good apart from that wink
Posted: Thu, 16th Jul 2009, 5:49am

Post 13 of 14

Axeman

Force: 17995 | Joined: 20th Jan 2002 | Posts: 6124

VisionLab User VideoWrap User PhotoKey 5 Pro User MuzzlePlug User PowerPlug User PhotoKey 3 Plug-in User FXhome Movie Maker FXpreset Maker MacOS User

SuperUser

Okay then; I'm sure both of those are situations they are well aware of, so hopefully we will see modifications in those areas in the future. Hope all goes well with your project over the next few days.
Posted: Thu, 16th Jul 2009, 5:58am

Post 14 of 14

Captain Amazingly Incredible

Force: 2000 | Joined: 14th Nov 2006 | Posts: 105

VisionLab User VideoWrap User MacOS User FXhome Movie Maker

Gold Member

Oh, I forgot - one more thing! U N I V E R S A L B I N A R Y. lol.