You are viewing an archive of the old fxhome.com forums. The community has since moved to hitfilm.com.

plugger problems (animation)

Posted: Sun, 20th Oct 2002, 8:10pm

Post 1 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

1.
ok I am trying to make my first animated plug-in.
when I put it in the plugger it loads all the frames wierd. I have put them in order like 01,02,03.....10,11,12 like the tut. says but it likes to load them in whatever order it wants to. am I doing something wrong?

2.
when I figure the first part out do I need to add an alpha to every frame?

3.
the plug-in would be used for a fire extinguisher, fire hose or something like that. anyway how would I make it were I can make it come out of the object and then be loopable were it does not start over each time?

I will give out a yummie for each question anwsered! biggrin
(I only have three)
Posted: Sun, 20th Oct 2002, 8:18pm

Post 2 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

In a plugger, do u set the loop starting frame, if u have create 50 frame for the animation, set it 50.

ada
Posted: Sun, 20th Oct 2002, 8:19pm

Post 3 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

it is 54 frames and yes I did add it
Posted: Sun, 20th Oct 2002, 8:24pm

Post 4 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

where did you animate your animation?
Posted: Sun, 20th Oct 2002, 8:25pm

Post 5 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

particle illusion, and I put into frames using video match (it is a free program, if you don't know what it is)
Posted: Sun, 20th Oct 2002, 8:28pm

Post 6 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

Then u export it to images?
Posted: Sun, 20th Oct 2002, 8:41pm

Post 7 of 21

lincon

Force: 70 | Joined: 6th Oct 2002 | Posts: 12

Member

Rating: +1

To answer all questions.

the numbers will go out if you use 1, 2, 3 and so on.
the plugger will change them in the end, so use a, aa, aaa, aaaa, b, bb, bbb, bbbb, c, cc
and so on.

A alpha channel needs to be on every frame ( if you don't want it to have a black border ) and it needs to be a tiff.
Leave the overlay set on the plugger to " overlay "

To loop an effect click on the
effect animation a loop
then click difine layers and leave as 0
to make a plugin loopable it would need to finish with the same frame as it starts.
eg: fire is easy as it looks the same, but a trex would need to end up in the same position it started in.
or you could add a flash of light on the last frame, so people would not see the " jump " from the last frame back to the first.

I hope this helps.
Posted: Sun, 20th Oct 2002, 8:44pm

Post 8 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

Good licon
Posted: Sun, 20th Oct 2002, 8:47pm

Post 9 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

my plug-in is a bust of water. after it starts to flow well how would I make that loopable without it starting back at the end
Posted: Sun, 20th Oct 2002, 8:48pm

Post 10 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

I just miss the 1,2,3 frame, i made it like this 1, 11, 111, 1111, 2, 222.... and so on, u should give him +3
Posted: Sun, 20th Oct 2002, 8:54pm

Post 11 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

Rating: +1

I think there is no way but u can make two animation, first u make the animation from start to end, then u creat other animation as u want it to continue
Posted: Sun, 20th Oct 2002, 8:55pm

Post 12 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

ok

you got question #3 so you get a plus 1

lincon needs to put another post here so I can give him another yummie
Posted: Sun, 20th Oct 2002, 9:02pm

Post 13 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

Thank WiRyPoCkEtLiNt, did you get what i mean
Posted: Sun, 20th Oct 2002, 9:08pm

Post 14 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

yes
Posted: Sun, 20th Oct 2002, 9:44pm

Post 15 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

I did what lincon said and it made my animation go backwords! (in the right order though)
help cry
Posted: Sun, 20th Oct 2002, 9:52pm

Post 16 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

It cannot be fix because it is the right way, what u can do is go to alam an reanimate it to play foward and export t to images in a file and it will work, i promise.
Posted: Sun, 20th Oct 2002, 10:15pm

Post 17 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

ok
Posted: Mon, 21st Oct 2002, 7:02am

Post 18 of 21

lincon

Force: 70 | Joined: 6th Oct 2002 | Posts: 12

Member

Rating: +1

Thanks for the force points, what a nice community.

I think ada1989 is right if your flow starts from 0 ( not water ) then starts to flow, that would not be loopable, you would need to make 2 plugins.

If you must number the frames insted of using the a,b, c's then this is how you number them for it stop stop going out of sequence.

waterflow_0001
waterflow_0002
and so on, this will work and not change when it gets to 11 or 21 etc.

The only thing I could say about your backwards plugin, is to rename each frame ( i know it takes a while ) to make it quicker when renaming do this
a_0001
a_0002
a_0003
Just use a it's quick than typing in waterflow.

good luck
Posted: Tue, 22nd Oct 2002, 12:35am

Post 19 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

ada1989 wrote:

It cannot be fix because it is the right way, what u can do is go to alam an reanimate it to play foward and export t to images in a file and it will work, i promise.
I have not yet bought alam so I can'y export. Can I e-mail you the plug-in and you revearse it for me. then you can send it to me fixed and I'll upload it?
Posted: Tue, 22nd Oct 2002, 8:17am

Post 20 of 21

ada1989

Force: 1994 | Joined: 14th Sep 2002 | Posts: 695

Gold Member

ok, i'm now in the middle of school confused , i will send you went i home.
Posted: Tue, 22nd Oct 2002, 12:50pm

Post 21 of 21

wpl

Force: 1782 | Joined: 17th Jul 2002 | Posts: 1389

Windows User MacOS User

Gold Member

ok

I need your e-mail so I can send it to you